AGlobeAwareDefaultPawn modification. Nodes not accessible in blueprint

Hello I’m trying to modify the AGlobeAwareDefaultPawn so I can move the camera in a different axis.
I added these lines to the header file:

UFUNCTION(BlueprintCallable, Category = “Movement”)
void MoveUp_View(float Val);

and these line to the cpp file
void AGlobeAwareDefaultPawn::MoveUp_View(float Val) {
this->_moveAlongViewAxis(EAxis::Z, Val);

which is basically the same than MoveRight method, but using different axis.

Could you help me to find out why I can’t access to the MoveUp_View in my level blueprint. and why in the level blueprint I can only access the moveRight function of the DefaultPawn and not the one belonging to AGlobeAwareDefaultPawn as I’d like to?

Thanks in advance

You can’t access MoveRight in AGlobeAwareDefaultPawn from Blueprints because it’s not marked as a UFUNCTION. Your new MoveUp_View is, though, so I would expect that to work. But you’ll need to recompile the plugin after you’ve changed the C++ code. Have you done that?

Hello, thanks a lot for your reply. I thought i did that, as I recompiled the project in visual studio after making the changes.
is that what you mean when you say recompiling the plugin? or am I missing a step I should take to recompile the cesium related content?
I also marked MoveRight as UFUNCTION in the AGlobeAwareDefaultPawn class, but I can only access the MoveRight from DefaultPawn in ue5, not the one from AGlobeAwareDefaultPawn.

Thanks again for your answer. Much appreciated

Is the plugin in your project? If it is, compiling the project in Visual Studio should also build the plugin. But if the plugin is in the Engine/Plugins directory (as it would be if you installed it from the UE Marketplace), compiling your project won’t do anything to compile the plugin.

Hello Kevin. thanks again for your reply. I’m afraid yes, my cesium plugin is in my Engine/Plugins directory. Based on your comment, is there a way to change that?, so the cesium plugin gets recompiled when compiling the visual studio project.

One million thanks

You can follow the Developer Setup instructions:

You may be able to skip some steps and simply copy the installed plugin into [your project]\Plugins\CesiumForUnreal, rather than building it from source from scratch. I haven’t tried that in a long time, but I think it will work.

Thank you soooooo much!!. I will definitely try that. Thanks a lot for your help. it’s so much appreciated. Have a great day!!!

hello! just to say thanks. that solved the issue! Thank you so much!
For the record, I took the easy approach (moving the folder, generating the vs files, compiling in VS and it worked!
Thank you!!!