Cesium and Google Servers

I have 2 Google enterprise servers in my organization.
With the first one, version 4, i have no problem and using the GoogleImageryProvider is working fine.
Now, we installed a new server, version 5. Now, with the same code, when i'm trying to enter the web page, i get an error - " Could not find a version in channel (id)".
I saw that there are 2 main differences between the JSON i got in the old version and the new version:
- In the old version the ID (channel) is integer and in the new one is GUID.
- In the old version the JSON contains version, and in the new one no.

anyone have any ideas? Is it possible Cesium is not supporting Google Enterprise Version 5? I tried this with the b-25 anf b-26 versions...

Can you post a copy of the JSON file from version 5?

I’m working successfully with b25 and GEE 5.0.

Try to see what’s the url cesium trying to get in the network tab in the browser.

The URL is ok, it's going to the /query?request=json&vars=geeServerDefs&is2d=t
but the JSON i'm getting is:

isAuthenticated : false,
layers :
description : " ",
id : "f8246316-989b-11e3-816e-397440017eff",
isEnabled : true,
isExpandable : true,
isInitiallyOn : false,
isVisible : true,
label : "Imagery",
lookAt : "none",

I think you are tying to connect to a 3D publish point.
Cesium works with 2D publish point, and get the terrain from outer provider

I saw in the server that the imagery is defined as 3D, but i didn't saw how to change it to be 2D...

You need to create a 2D database in fusion and than publish it

Ok it seems that the 2D solved the problem.
but now how can i add the height to the layers?

You can’t get the height from GEE server.
you should get it from some outer terrain provider