KML - SchemaData is unsupported

KML is getting distorted.Getting a warning of schemadata is unsupported.What would be the cause?

I think by default KML geometry is clamped to the ground, which is why I’m guessing that polygon is distorted (projected onto the earth). See Matt’s response here about setting an altitute mode:

As for the warning, can you post the full message you get?