Scaled up map size issues (Project anywhere XR)

Hey all, I have been tinkering with Project anywhere XR with the Hololens 2 platform and have ran into some issues I have been trying to fix.

I have scaled up the map size in order to see a larger area easier whilst viewing the project through Hololens. The scale up size has been done by increasing the clipping box size to 1000.00, As well as increasing the table size and it components to match the scale of the map at 40.00. The overall display is excellent and is perfect for the project I am working on, However the are some issues I wish to address in order to make the map function as it did when at a smaller scale.

These are the Issues below, Any help will be greatly appreciated:

  1. Map can no longer be moved (Except through the use of the long/lat/alt co-ordinates options within the GeoRefrence component settings). Controller input via hand display does not work.

  2. Map can no longer be zoomed in (Have yet to find the component options to attempt increasing zoom onto the map manually) Controller input via hand display does not work.

  3. Global pins/location selection does not work as have tried to change map location through the menu but no reaction on the map nor long/lat/alt co-ordinates.

  4. When previously moved at a smaller scale (Before scale increase) movement on the map resets to original location.

My guessing at the moment is that I must scale up a component in order to allow for the movements to correspond with the increase in the size of the map and table overall, However my searching for such a component to allow this has yet to yield results. I have looked around in the blueprints as well as lurked on these forums in order to find a solutions but to no avail.

I have attached images
below for all to see the scale and give some idea as to what I have missed here.

Any feedback/ideas are massively appreciated.


Hi @AJW184,

We are not currently providing ongoing support for Project Anywhere XR. However, based on your description of the issue, I’d guess that there’s a collider on the terrain or table that is getting in the way now that you have scaled up the map. You may want to take a look at the collision settings on each of the gameobjects in the scene. You could also try stepping much farther back to see if that has any effect on the controls.

-Alex

Hi Alex,

That’s a shame. I did manage to solve the issue by scaling up the whole model via the blueprint model editor. This seemed to work however I still am having some issues when it comes to map movement as sometimes the map resets to the original position. The zoom feature works well, It’s just the movement on the map that has issues. Hopefully I can get around the issues as I continue to tinker with the project.

1 Like