Cesium crashes while loading 3D tiles


My Cesium client is crashing whenever I try to load most (but not all!) 3D tileset examples found online.

For instance, all the sample 3D tilesets generated by 3d-tiles-tools (EXCEPT the TilesetWithDiscreteLOD) throws the following error:

--------- ERROR BEGIN

An error occurred while rendering. Rendering has stopped.
RuntimeError: Operator “>=” requires number arguments. Arguments are undefined and 300.
at new t (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:472:3926)
at A._evaluateGreaterThanOrEquals (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:529:20241)
at p.evaluate (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:529:14616)
at n.evaluateColor (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:530:17)
at R.applyStyle (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:523:17612)
at C.applyStyle (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:524:646)
at r.applyStyle (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:528:13817)
at Q (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:528:21744)
at F.update (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:528:26462)
at a.update (http://localhost:8080/Apps/my-custom-client/current-version/libs/Cesium/Cesium-1.41/Build/Cesium/Cesium.js:538:1379)

--------- ERROR END

I tried to test other sample 3D tilesets (based on .b3dm files), and they all throw the same error.
(Again, the only exception is TilesetWithDiscreteLOD which behaves and displays OK, as well as the NYC sample tilesets.)
What might be the reason for this occurring?

Just to check that it is not the version of the Cesium I’ve been using (1.38), I upgraded to 1.41 but got the same results.

  1. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

I use the following standard code:

var tileset = viewer.scene.primitives.add(new Cesium.Cesium3DTileset({
url : ‘http://localhost:8003/tilesets/TilesetWithDiscreteLOD/’ // loads OK
//url : ‘http://localhost:8003/tilesets/BatchedWithBatchTable/’ // crashes

  1. Context. Why do you need to do this? We might know a better way to accomplish your goal.

I am studying the 3D tiles spec, and planning to eventually generate my own 3D tileset.

  1. The Cesium version you’re using, your operating system and browser.

Cesium 1.41, Windows 10 64-bit, Version 1709, OS Build 16299.192
I reproduced the errors above on all three major browsers (Chrome, Edge, Firefox).

Thank in advance for any pointers,


Do you have the full code that’s crashing. It seems like a style is failing because it references a property that the tileset doesn’t contain. TilesetWithDiscreteLOD is one of the few tilesets that doesn’t contain features (i.e. batch ids) so it does not get affected by invalid styles.