[cesium-dev] Cesium 1.7 Infobox error

This was an issue that slipped out with 1.7, we have already release 1.7.1 to fix it: http://cesiumjs.org/2015/03/02/Cesium-version-1.7.1-released/

Hi Matt,

On the topic of InfoBox in Cesium 1.7.1, Chrome 41.0 (Ubuntu) throws a sandbox error on about:blank.

“Blocked script execution in ‘about:blank’ because the document’s frame is sandboxed and the ‘allow-scripts’ permission is not set.”

This started happening after upgrading to Cesium 1.7.1 and after reading about the updates to InfoBox, I presume the issue is related.

I am serving Cesium from an HTTPS site with a self-signed cert.

It’s not an issue but wanted to make your team aware and see if there were any workarounds other than modifying about:flags?


  • Chris

Thanks, I’ll make a note for us to look into this. Originally we weren’t even loading about:blank, but the browsers all behave differently if you don’t load some form of page. I think the solution may be to create an empty document to use rather than relying on about:blank.

Chris, I looked into this and I can’t personally reproduce the problem. What do you see when you go to about:blank in that browser? (be sure to view the source) On my machine it is completely empty. It’s possible that you have some content scripts being injected into about:blank by various Chrome plug-ins and that’s what’s being detected by the iframe sandbox and putting up the error. It’s a harmless error, but I want to understand if it’s something we should be doing differently on our end.

Just FUI.
I see the same error message in Chrome on Windows. about:blank source is empty.


I’m using Chrome on Windows 7 at the moment and I do not see the following error you are referring to. Are you sure it’s Cesium or perhaps your Chrome is outdated?


Alex, is this with the server that ships with Cesium, or your own server? Can you describe your server setup? I’ve tried this both under http and https on Windows and UNIX and can’t reproduce it.

If you go to chrome://extensions/, what do you have installed?

server: nginx, default setup (almost)
extensions: Adblock, Postman