Clipped Tile Meshes

I’m running into an issue where the colliders of large buildings that are outside of my clipping radius are blocking interaction with those inside the radius.

I know that tileset clipping is purely visual, and it does not actually clip the underlying mesh, but is this the indefinite expected behavior or is mesh clipping on the roadmap?

I’d appreciate any additional insight here or any suggestions I could explore. I need the meshes of the buildings to be interactable, otherwise I’d just disable the colliders and interact with a plane at the base level of the map instead.


It sounds useful to be able to disable the colliders of those clipped buildings, but maybe a simpler question first…

Wouldn’t you want to start your collision ray from inside the clipping area anyway?

First thought is that this should create a smaller ray, which in theory should be more performant. But a side effect would be that it wouldn’t get a chance to collide with anything outside that area, like those hidden buildings.

1 Like

Hey @Brian_Langevin,

Thank you for that suggestion! Hadn’t really thought of that, but it worked perfectly. We’d still love to see the colliders be clipped at some point, but this is a great work around.

1 Like