Error when adding any assets


I am getting a stream of errors whenever I add tilesets. I’ve tried the built in Bing Maps Aerial Imagery and also a separate tileset of 3D tiles I’ve uploaded to Cesium Ion.

[Warning] (Cesium) - [2022-04-13 17:37:49.872] [warning] [GltfContent.cpp:97] Warning when resolving external gltf buffers from
- Attribute accessor.count doesn't match with number of decoded Draco vertices.
- Attribute accessor.count doesn't match with number of decoded Draco vertices.
- Attribute accessor.count
[Error] (MaterialAsset) - MaterialTypeAsset is null
[Error] (MaterialAsset) - Cannot continue building MaterialAsset because 1 error(s) reported
[Warning] (MeshFeatureProcessor) - No material provided for mesh. Skipping.

The last Warning repeats itself everytime I pan the camera, it is not even loading the mesh without the material.

Any help would be appreciated.


I’m currently looking into the issue. Can you check in your project directory if there are any files with the name gltfstandardpbr_*.azshader under the Cache/pc/materials/types subdirectory? I suspect the AssetProcessor may not finish processing those shaders, which creates the issue like above. If that’s the case, I would suggest to wait for AssetProcessor to finish and open the editor again. This typically happens only the first time when building the project

Another thing to check is that in the past, we encountered an issue where AssetProcessor failed to find any custom shader files in the Gem if the Gem directory was placed within the client Project directory. Can you please check if it’s not the case?


I created a new project from scratch, built it with the Cesium Gem and waited for the Asset Processor to complete before I went ahead and tried to add anything. Still throwing the same errors.

Can confirm there are 6 files with the format gltfstandardpbr_*.azshader in that directory, as well as hundreds of others with file formats .azshadervariant, .azslin and .json.

The Cesium gem is located in my %USER%/Documents/O3DE/Gems folder. I also created another project with the Gem folder on my Desktop, let the Asset Processor do it’s thing and tried again but no luck, still the same errors.

After it failing with the second project, I saved and restarted the Editor and the Processor. Upon launching it a second time it appears to want to work! Seems a restart is necessary in some circumstances. Also noted that the Asset Processor needs to be manually closed after closing the Editor otherwise the same error will appear if you load the Editor again.