Giant lens flare?

Hi all,

Just started trying out Cesium and upon adding CesiumSunSky I get a MASSIVE lens flare!

Where are the settings to turn this off?


I’m not entirely sure what you mean by “lens flare”. I only know this as the name for a visual effect, and don’t think that this is supposed to happen here.

But a guess: When you add the CesiumSunSky, then the scene may look “far too bright” for a short amount of time. This is most likely because of the intensity of the directional light that is associated with the CesiumSunSky. The sun is very bright. It’s the brightest thing in the world … well, that doesn’t make sense. It’s very bright, though…

Some technical background information about that can be found in the section Using a Geospatially Accurate Sun → Sun Intensity of the learning center.

If this flash of brightness is what you refer to: This should adjust itself after a few seconds. If this is not what you meant, maybe a screenshot could help to clarify it…

Hi @oandroido,

To add on to what Marco said, if you are seeing a lens flare that looks like this, rather than overall screen brightness:

there are two things I can think of that could be causing it. First, check in your World Outliner. If you see an actor called “PostProcessVolume” in the level, that is likely what’s causing the effect. You can either delete the volume, or adjust/disable the lens flare settings in the details panel of the Post Process Volume.

If there is no Post Process Volume in the scene, it’s possible that it’s set in your project settings. Even without Post Processing in the scene, projects allow for several post processing effects to be applied in the project settings, which would effect all cameras and scenes in the project.
Open the project settings (Edit/Project Settings) and search for “Lens”. You’ll see a setting called “Lens Flares (Image based)” in the Engine/Rendering settings. If that option is checked, be sure to disable it.


Hi Folks,

Here you go :slight_smile:
Can’t see it here but the two rectangular shapes seem to be filled with sky/clouds.
Note that once a terrain is added, it’s much less noticeable, if at all.

Also, I’ve found that when I re-enable terrain visiblility, I get the black band on the horizon again, and need to delete & re-add the CesiumSunSky to get it to go away.

Hi @oandroido,

Looks like that is a combination of the auto-exposure and the lens flare. I’d recommend adding a Post Process Volume to the scene so you can control them better. This tutorial might be useful to you.

With the black band on the horizon, I’ve seen an issue like that before. In that case, it was caused by CesiumSunSky not being positioned correctly, since it only creates a sky on the top half and the bottom half is black. Make sure your SunSky is connected to your Georeference, since the Georeference should be handling the positioning.

I haven’t seen that issue specifically relating to terrain visibility, though. So I can get a better idea of the problem you’re seeing, how are you enabling and disabling terrain visibility? Does the black bar happen every time?


1 Like

Hi Alex-

I’ve tried to re-create this a few times with new files and haven’t been able to reproduce it.

Disappointing, but I think it’s a good thing :slight_smile: