glb sideways

I'm using a glb... but it's coming up 90 degrees to the left ?!? how may I
adjust it 90 degrees to the right?


Hey Robert,

Load a gltf model with Model.fromGltf, and if the rotation is still a problem, try specifying the rotation matrix in the optional modelMatrix option.



It’s possible your model is Z-Up while Cesium expects models to be Y-Up. In addition to Gabby’s suggestion, Model.fromGltf has an undocumented option to specify the up-axis when creating it, just pass in upAxis : Cesium.Axis.Z as one of the options.