Having problems rendering 3d models and animating (sampledPropertyPosition) them after 1.48 upgrade

Upgraded to 1.48 from 1.25 yesterday.
Since than having problems rendering 3d models, they show up randomly when refreshing the page several times but not moving according to the sampledPositionProperty.

Everything worked perfectly on 1.25, tried downgrading back to 1.25 and it worked again.
Am I missing a major change in one of the versions greater then 1.25 ?

This is how I'm creating the entities :

                var sampledPositionProperty = new Cesium.SampledPositionProperty();
                sampledPositionProperty.addSamples(times, positions);
                var heads = ;
                var sampledOrientationProperty = new Cesium.SampledProperty(Cesium.Quaternion);
                for (var i = 0 ; i < positions.length ; i++) {
                    var hpRoll = new Cesium.HeadingPitchRoll(Cesium.Math.toRadians(90), Cesium.Math.toRadians(0), Cesium.Math.toRadians(180)); // (1) (Changed aswell to support 1.48 as it was not working after the upgrade)
                    heads.push(Cesium.Transforms.headingPitchRollQuaternion(positions[i], hpRoll));
                sampledOrientationProperty.addSamples(times, heads);

                var entity = new Cesium.Entity({
                    position: sampledPositionProperty,
                    orientation: sampledOrientationProperty,
                    model: {
                        scale: 1,
                        uri: '../../assets/satellite/sat_simple.glb',
                        minimumPixelSize: 1.5 * size


Apart from the change above (1), nothing was changed in the code.

Just to add some information :

Upgraded in order to support tilesets

When the models actually show up (once in a while), they dont move.

Using chrome while disabling cache.

Not receiving any errors, one warning :

Entity geometry outlines are unsupported on terrain. Outlines will be disabled. To enable outlines, disable geometry terrain clamping by explicitly setting height to 0.

It is strange that the models aren’t always appearing. Just to try to narrow it down, does the problem go away if you pass a Cartesian3 as a position instead of SampledPosition?

This sounds like it might be easy to recreate in a small example, so if you can put together a running Sandcastle example that you can share here that’ll really help. This example loads some 3D models you can use to test:

It does go away if I pass a Cartesian3 instead of SampledPosition.
I moved to 1.38 as I already had a copy in another project and everything works fine now.. (havent tried 1.39 -> 1.44, 1.45 suffered from the same problem)

I couldnt reproduce it using the above 1.49 sandcastle..
(Pasted my code and it worked as expected)

I will try to isolate the behaviour and get better insights.

Thanks for the info! Yes, please post back here if you can reproduce it especially if it’s with the latest version. That’ll give us enough info to look into and fix it.