How to get more zoom level on 3D Tiles with Terrain

We need to get more zoom level on 3D Tiles with Terrain. Example.

In this example we load a 3D Tile and try to get maximum zoom level, but the zoom in stop at a certain level.

However, when we don’t use the Terrain Provider (//viewer.terrainProvider = terrainProvider;)
it is possible to obtain a “complete” zoom in level.

Are you loading your own 3D terrain in this scene, and your own satellite imagery?

Are you able to share a Sandcastle example reproducing this issue? See How to share custom Sandcastle examples

Thanks @omar.
I already shared it above. (Sandcastle) . I’m using the Cesium World Terrain.

Thanks, I missed your earlier link.

The problem here is that the tileset is actually underneath the terrain. It’s visible only because depthTestAgainstTerrain is turned off, which means the tileset can be seen through the ground. The camera won’t let you get any closer because it’s hitting the ground. You can fix this in a couple of ways:

  1. Allow the camera to go underground, by disabling collision detection:
  2. Move the 3D Tileset a few meters up. You can do this using the Cesium ion “Adjust Tileset Location” editor or programmatically like in this example
  3. Use clipping planes to clip out the terrain in that area: