Mysterious Black Dot

Hi all,

For a while in our application, we have been experiencing a mysterious black dot appearing in the upper third of our screen. It seems to stay in the same place regardless of the direction of the camera, but it can be occluded if there is a Cesium entity in front of it. It changes shape slightly, but seems to consistently affect two or so rows of pixels on the same area of the screen.

Does anyone know what might be causing this? It has been vexing my team for quite some time now, and we can’t figure out where it is coming from.

Here it is appearing in the sky
Screen Shot 2021-03-10 at 7.39.38 AM

Here it is slightly obscured by some semi-transparent walls.
Screen Shot 2021-03-10 at 7.42.22 AM

Screen Shot 2021-03-10 at 7.40.51 AM

Any advice you might have would be very helpful!

1 Like

Hi! What you are seeing might be the moon. Can you try setting viewer.scene.moon = undefined and see if it’s still there?


Thanks for your response. I should have specified that that was our initial thought, we had tested that before and we still get the same result. I tried it again just now too (just to be sure) and that weird little dot is still there.

I feel like it must have something to do with either the scene or the camera, however, as it always stays at the same spot within the viewer.

I’m curious whether this is caused by some other asset in the scene. If you take away all of the assets and just have the base globe with imagery, is the dot still there?

Ah ha!

I removed an entity that was an aircraft that our camera was fixated on and that appeared to get rid of it. Because that entity was always in the same spot on our screen, that would explain why the spot was always in the same position. The dot appears to change in shape as I circle the entity with the camera too, seeming to suggest that it has some 3-dimensionality that is tied to the camera’s perception of the aircraft.

The curious thing now, however, is that the .glb file that we have used for the model in this entity has been altered a few times, yet we have consistently experienced this same phenomenon. Also, the black dot appears to be far off in the distance, as it can be occluded by pretty much any other entity, which doesn’t seem to make sense considering the fact that it appeared to change shape as I circled the aircraft. How could I be getting a different perspective on this dot if it is far off in the distance? It would seem that it cannot be the effect of the imported .glb file if it is so far away and appears to be moving with the camera.

I am going to start experimenting with different types of models or entities that I could put in place instead of the aircraft that is there currently to see if it changes anything.

Could that dot be part of the aircraft model unintentionally? You can test this by showing the extent of the model. Depending on how you are loading the model you could turn on bounding sphere with debugShowBoundingVolume.

That’s a good idea! I’ve been trying this in my implementation though, and I can’t seem to get it to work. I also tried to do it in sandcastle on the 3D models page. I added “debugShowBoundingVolume: true,” to the models options in both cases and nothing came up. What conditions allow you to see the bounding volume?

Follow up on this for anyone who’s interested. I solved it!

Turns out it was a problem with the .glb file that I imported. I edited the file in Blender and was able to get rid of it. I believe the reason that it was being occluded actually had something to do with its z-index, though I haven’t been able to confirm that. Nevertheless, if you’re experiencing a mysterious black dot like me, it might be an error with an imported .glb file :slight_smile:

1 Like