Overlapping polygons rendering incorrectly with clampToGround

Hi There:

I am having an issue with overlapping polygons with Cesium.GeoJsonDataSource with clampToGround set to true.

Here is what I see:

When I set clampToGround to false, then the polygons render correctly like they should:

But in this application it is essential to have the polygons clamped.

Any ideas?



Ricardo, what Cesium release are you using? Can you post a link to the json?

Hi Jon,

I am using version 1.44 and here is a link to the json (actually topojson) file: https://stable-data.oregonhowl.org/rcwildfires/2017/Eagle_Creek.json

Thanks a lot for looking into it.


The attached file is probably more useful…

I am playing around with entity availability so I removed all the data starting from the item in the geometry collection where I see the problem. If you just load this GeoJsonDataSource, you should see the issue.

Thank you,


test.json (2.05 MB)


This code snippet below worked
fine in Sandcastle on my localhost running Cesium 1.43

I ran the code snippet below
with both of your data samples, with clampToGround set both true and false,
with both terrain providers.

The Cesium viewer initially
loads with the WGS84 ellipsoid. Use the BaseMapPicker to switch terrain
provider from the ellipsoid to STK World Terrain.

The data on oregonhowl.org
server loaded okay, but I may have missed something.

The test.json from my
localhost also loaded okay with this code.

I am stumped, after an hour
and a half, but your free support time is running out…

What I noticed was the
test.json disappears under the terrain when clampedToGround is false, using STK
World Terrain.

That leads me to suspect it
is a data issue, not a Cesium clamptoGround issue.

I’ll let you know if I have
any other ideas.

It’s an interesting project, I
hope you can get it working.


Hi Jon,

I really appreciate your time. Thanks a lot.

The first link I sent you “appears” to work but that is because there are additional geometries that obscure the problem – so you may not quite notice it. That is why I sent the second file (which I have now posted here: https://stable-data.oregonhowl.org/test/test.json).

Running your snippet with the second file (link above) with no terrain you can see it ok, but only of you use {clampToGround: false} – if you set it to true you can see the anomaly (big missing fill area).

I would not discard a data issue, but I can see the file just fine with mapshaper, so I am not convinced.

Perhaps someone in the Cesium team can look at the issue?

BTW, the project is working pretty good when I show one geometry at a time using entity availabilities. You can see it working right here. I am just exploring other ways of presenting the data.



Hi Ricardo,

I see you opened issue #6448. We’ll track the bug there, and I cross-linked the discussion here as well.

Thanks for the report.