Picking problem after updating to latest Cesium

We’re using Cesium 1.3 until now, and I now tried to upgrade to 1.6

Now all picking code is broken, when drillPick() is called there is an exception:
Uncaught DeveloperError: id is required

IDs are required now for picking?
I did not find anything in the change log related to this.

I tried passing a custom id to my primitives, however it is not working…
I tried adding an id to a constructor both in a GeometryInstance and a Primitive, none seem to work!

Also I checked the constructor of the primitive, found no code there related to getting a id from arguments and storing it on the instance fields.

Also I looked at the sandcastle picking sample, found no custom IDs in the primitives creation code, why?

Can you please post a complete Sandcastle example that shows the problem?

Never mind, I found the problem. This was indeed a bug introduced while fixing another picking related bug. Thanks for the report.

You can work around the issue by specifying an id, here’s a code snippet that does that: https://github.com/AnalyticalGraphicsInc/cesium/blob/master/Specs/Scene/PickSpec.js#L172

Yes, I was able to make it work, thanks :slight_smile: