Problem with hello world script

1. A concise explanation of the problem you're experiencing.

I am running the Helloworld tutorial as found here

I have installed Cesium and nodejs as explained.
Then ran npm install in the Cesium root directory.. It installed a bunch of stuff(dependencies?) in the folder node_modules

I then type node server.js
I get a bunch of errors.

Error log found in npm-debug.log is attached

0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/nodejs', '/usr/bin/npm', 'start' ]
2 info using npm@3.5.2
3 info using node@v4.2.6
4 verbose run-script [ 'prestart', 'start', 'poststart' ]
5 info lifecycle cesium@1.38.0~prestart: cesium@1.38.0
6 silly lifecycle cesium@1.38.0~prestart: no script for prestart, continuing
7 info lifecycle cesium@1.38.0~start: cesium@1.38.0
8 verbose lifecycle cesium@1.38.0~start: unsafe-perm in lifecycle true
9 verbose lifecycle cesium@1.38.0~start: PATH: /usr/share/npm/bin/node-gyp-bin:/home/srinath/Cesium/node_modules/.bin:/home/srinath/logReader:/home/srinath/logReader/quatosReader:/home/srinath/logReader/cartosReader:/usr/share/crossworks_for_arm_2.3/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
10 verbose lifecycle cesium@1.38.0~start: CWD: /home/srinath/Cesium
11 silly lifecycle cesium@1.38.0~start: Args: [ '-c', 'node server.js' ]
12 silly lifecycle cesium@1.38.0~start: Returned: code: 1 signal: null
13 info lifecycle cesium@1.38.0~start: Failed to exec start script
14 verbose stack Error: cesium@1.38.0 start: `node server.js`
14 verbose stack Exit status 1
14 verbose stack at EventEmitter.<anonymous> (/usr/share/npm/lib/utils/lifecycle.js:232:16)
14 verbose stack at emitTwo (events.js:87:13)
14 verbose stack at EventEmitter.emit (events.js:172:7)
14 verbose stack at ChildProcess.<anonymous> (/usr/share/npm/lib/utils/spawn.js:24:14)
14 verbose stack at emitTwo (events.js:87:13)
14 verbose stack at ChildProcess.emit (events.js:172:7)
14 verbose stack at maybeClose (internal/child_process.js:821:16)
14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)
15 verbose pkgid cesium@1.38.0
16 verbose cwd /home/srinath/Cesium
17 error Linux 4.4.0-96-generic
18 error argv "/usr/bin/nodejs" "/usr/bin/npm" "start"
19 error node v4.2.6
20 error npm v3.5.2
21 error code ELIFECYCLE
22 error cesium@1.38.0 start: `node server.js`
22 error Exit status 1

Running on Ubuntu 16.04, browser = chrome

What am i doing wrong ?

Hi there,

I downloaded the latest Cesium, and extracting the zip, navigated to that folder, and ran:

npm install

npm start

And it worked fine. I also tried node server.js instead of npm start. That worked fine as well. Did everything install correctly? Try running npm install again and make sure you’re not getting any errors. Also double check you’re running the command in that root folder.