Touchscreen bug with Firefox

Hey guys,

There is a bug in the touchscreen gestures when running in Firefox.

The two finger gesture to zoom in does not actually zoom in on the map. Instead, it zooms in/out only on the overlay controls (the clock, search button, home button, etc).

I verified this on the cesium hosted Hello World site. I have a touchscreen on Windows 8.

Just to follow up with more details - t he rotate gesture also does not work. The pan gesture to more around DOES work.

I can’t reproduce this. I tried both the iFrame embed on the home page and Hello World at using Firefox (37.0.1) on my Android (4.4.4). Everything worked as expected.

What devices/OS/Browser version are you using?

I am running 64-bit Windows 8 OS on an out of the box Dell laptop. I will get back to you on the Firefox version this evening when I have access to the device and will also retest.

Let me know any more information I can provide to help.

I have confirmed again this is still an issue on

Firefox version 36.0.1, Windows 8 64-bit laptop with touchscreen.

Because touch event standards on the web are such a mess, Cesium doesn’t support using both a mouse and touch on the same device at the same time. Once it detects one form of input, it disables the other (this may not be true with pointer-events in IE but I’d have to check the code). This is something we would love to address, but it’s not on any near term roadmap. We would be interested in a pull request if anyone is wants to work on it.

Here’s a related article