why the terrain looks different from upside and downside?

Hi everyone

I’m trying to visualize some underground objects.

Now my method is to re-define the viewer’s globe by using a smaller ellipsoid, and define the terrainProvider’s ellipsoid in WGS84. It works well. Now I can move the camera down to the terrain.

My problem is, when the camera is under the ground, I look up but can’t see the terrain, it is transparent.( I already remove the skirts )

When I am above the terrain, I can look down and see the terrain.

I don’t know why this happens?

Can I make terrain visible all the time? Or, even better, can I make the terrain semi-transparent I look up under the ground?

Any advice appreciated



Hello Chris,

The back side of the terrain is culled for performance reasons. I don’t think there is a way to prevent this from happening.

Cesium does not currently have good support for underground objects. It is probably one of the most requested features we get and is something we’d like to add soon, but we’re working on finishing the 3D tiles specification first.



Hi Chris,

Hannah is right. There is no way to do this through the API. If you want to change the source, disable back face culling:


In the render states, set the enabled property of the cull object to false.


Thanks Hannah and Dan

I will change the source to see if its performance