3D model not showing

Hello Support,

I am trying to load sample 3D models from downloaded folder.

I have tried .dae , .glb and .gltf formats. But any format not showing on the terrain. It is not visible. Even I kept sceneMode as Cesium.SceneMode.SCENE3D

My code is

var viewer = new Cesium.Viewer(‘cesiumContainer’, {

sceneMode: Cesium.SceneMode.SCENE3D


var scene = viewer.scene;

var position = Cesium.Cartesian3.fromDegrees(-123.0744619, 44.0503706, 5000);

var heading = Cesium.Math.toRadians(135);

var pitch = 0;

var roll = 0;

var orientation = Cesium.Transforms.headingPitchRollQuaternion(position, heading, pitch, roll);

var entity = viewer.entities.add({

name: “models/CesiumGround/Cesium_Ground.glb”,

position: position,

orientation: orientation,

model: {

uri: “models/CesiumGround/Cesium_Ground.glb”,

minimumPixelSize: 128,

maximumScale: 20000



viewer.trackedEntity = entity;


destination: Cesium.Cartesian3.fromDegrees(-123.0744619, 44.0503706, 5000)


What was the problem? Even I have tried in different browsers also. I tried loading my .html from webserver as well as local also.

The uri should be