3d tile building features

I added the sample file. Come on, I made a mistake here .

thank you.

ada.rar (146 KB)

I couldn’t pinpoint the exact problem, but it seems like a bug in the FME export.

I had the same problem when exporting 3D Tiles with FME for Cesium, not only with picking but also with styling. After hours of debugging, I found out when I change

semantic: '_BATCHID', to semantic: 'BATCHID',

in the Cesium source code (https://github.com/AnalyticalGraphicsInc/cesium/blob/7213d4d25e02deab085448250c5dca966f1dbfcc/Source/Scene/modelMaterialsCommon.js#L355), it works as desired. However, you will get another warning in the console: "The glTF in this b3dm uses the semantic `BATCHID`. Application-specific semantics should be prefixed with an underscore: `_BATCHID`".

Note that it is only a hotfix for a project, so either FME may update their writer or Cesium may improve its backwards-compatibility of the 3D tiles format in future.

I tried the uploaded tileset again on master and picking no longer seems to be an issue. Likely whatever the bug was it was fixed during the glTF 2.0 upgrade. If anyone can confirm with their data that would be helpful.

The flickery artifact should also be fixed now with this PR: https://github.com/AnalyticalGraphicsInc/cesium/pull/5773.

Hi Sean, both styling and picking works now out-of-the-box with my exported dataset and the current master. Thank you!