3d-tiles not loaded

As I know the cesium 3d-tiles branch was merged into master,so I use master to load 3d-tiles,but the model was not loaded. the code as below , the function 'allTilesLoaded' and 'readyPromise' were not excuted, What's the problem?

Hi there,

Double check your tileset path – I tested your code with a path to one of our sample tilesets and it runs just fine.

Also, be careful. You’re translating the tileset down 4000 meters, so it may be under the terrain.

Hope that helps,

  • Rachel

I'm having the same issue after switching to the master branch. I'm not translating my tileset at all so I know that's not the issue. I load in my tiles the same way as above and am also observing that

tileset.readyPromise.then(function () {...});

is never executing. If I switch back to the Cesium.js from the 3d-tiles branch, I don't have this issue.

You can also check if an error occurred with:

the error msg shown in otherwise function as below:

t {name: "RuntimeError", message: "geometricError must be defined", stack: "Error↵ at new t (http://localhost:8026/App/Cesi…://localhost:8026/App/Cesium/Cesium.js:516:27615)"}message: "geometricError must be defined"name: "RuntimeError"stack: "Error↵ at new t (http://localhost:8026/App/Cesium/Cesium.js:518:3793)↵ at new O (http://localhost:8026/App/Cesium/Cesium.js:569:30954)↵ at U.loadTileset (http://localhost:8026/App/Cesium/Cesium.js:571:7022)↵ at http://localhost:8026/App/Cesium/Cesium.js:570:31031↵ at i.then (http://localhost:8026/App/Cesium/Cesium.js:516:27615)↵ at http://localhost:8026/App/Cesium/Cesium.js:516:28189↵ at m (http://localhost:8026/App/Cesium/Cesium.js:516:29571)↵ at f (http://localhost:8026/App/Cesium/Cesium.js:516:28325)↵ at r (http://localhost:8026/App/Cesium/Cesium.js:516:27823)↵ at i.then (http://localhost:8026/App/Cesium/Cesium.js:516:27615)"__proto__: Error

can you give me the cesium.js file directly; I'm sure that the tileset path was right

I have the same error message. Did an optional property of the Cesium3DTileset constructor get changed to required when the branch got merged with master?

Geometric error is required for every tile, but previously the engine was not checking whether it actually existed. Most likely this resulted in a bunch of checks against ‘undefined’ which may have accidentally worked due to the nature of JavaScript.

For anyone else stumbling upon this thread, a fix for this problem is here: https://groups.google.com/d/msg/cesium-dev/3p5XyXAzkbs/LOwd6rYdBgAJ