3dtiles error when upgrade cesium to 1.97

I have a 3dtiles set that works on cesium 1.82.
After upgrading to 1.97 I get errors:
‘=’ : dimension mismatch
‘assign’: cannot convert from ‘highp 2component verctor of float’ to ‘highp 3-component vector of float’

any idea?

Hi @attar.tal,

Does your tileset contain glTF 1.0 models? If so, then this may be connected to this issue on Github: glTF 1.0: treat vec2 normals as oct-encoded to prevent crashes · Issue #10821 · CesiumGS/cesium · GitHub

I’ll reference this thread on that issue. That way, when the issue is resolved, someone can post an update on this thread :slight_smile:

@attar.tal would you be able to share your tileset with us? I created a branch to fix this and I’m looking for more data to test with. You could also try it out yourself.

The link to the branch is here: glTF 1.0: treat vec2 normals as oct-encoded to prevent crashes · Issue #10821 · CesiumGS/cesium · GitHub

I tried the “old” New-York (https://cesiumjs.org/NewYork/3DTiles/NewYork.zip)

I ran the tile3d validator on one of the b3dm file and got the error:

Header is using the legacy format [batchLength] [batchTableByteLength]. The new format is [featureTableJsonByteLength] [featureTableBinaryByteLength] [batchTableJsonByteLength] [batchTableBinaryByteLength].

Ah thanks!

It’s an old tileset and you can ignore the validation error. We support older b3dm versions in CesumJS.

The branch seems to fix the shader crash but there’s still some artifacts with the normals. I posted a screenshot in the github issue.

@attar.tal , I ran into the same issue displaying the old New-York City data using CesiumJS version 1.106. I wonder if you have obtained a new New York City’s dataset, or have upgraded to a newer CesiumJS version to resolve the issue? Thank you in advance!

@sean_lilley , to follow up on my above post and assuming a newer CesiumJS version is available for displaying the old NewYork City b3dm dataset, do you have a recommended version number? Thank you.

@honglzhu you can try the latest version of CesiumJS but I think some of the rendering issues in the github issue still exist.

@sean_lilley , I just tried the latest V1.113, and I still see the same error for the New York City data:

@attar.tal , did you solve the issue (in your first posted in Sep 22). I tried the latest version, i.e., v1.113, but I am still getting the same error.

@sean_lilley , My tests showed that the NY City b3dm dataset can be displayed on or before v1.96. Starting from v1.97, that critical error occurred and it stopped any rendering.

If the data set needs to be upgraded, do you know if there are any such tools? (I tried 3d-tiles-tools, but it did not help.)

@sean_lilley , please disregard my above questions, since @javagl (Marco Hutter) from 3d-tiles-tools is helping me to fix the dataset issue.