A problem in rendering kml files

1. A concise explanation of the problem you're experiencing.

When load kml files into Cesium, it's ok if the kml file only contain dots(coordinates), but Cesium will crush if the kml file also contains other vectors like lines or planes.

This forum can't have pictures but i can tell you the loading is complete and success but the crush happens while rendering.

Now I've tried many different kml files to rule out if it's problem of the file itself, further debugging is beyond me, I'm afraid.

2. A minimal code example. If you've found a bug, this helps us reproduce and repair it.

Just the basic code

viewer.dataSources.add(Cesium.KmlDataSource.load('url', {
          camera: viewer.scene.camera,
          canvas: viewer.scene.canvas

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

We are hoping to load kml files and each coordinates are given different 3D models based on properties in the kml file to be displayed intuitively and vividly in Cesium.

4. The Cesium version you're using, your operating system and browser.

Cesium 1.46, Win10 pro 1511 64-bit, Chrome 67.0

Furthermore, please do improve the surpport of 3D model, particularly in texture and file format(3ds obj open collada etc.)

How large is the KML file? There is a detailed explanation in this thread that goes into the details of why Cesium may hang when loading large amounts of data. Ultimately is you’re file is too large, the solution would be to convert your data to 3D Tiles, a format optimized for streaming in the browser.

Can you provide a sample KML which duplicates the error?



Thank you

I've found the problem, it's about browser compatibility.

My IDE have a build-in browser based on chrome or chromium, provide real time display of my codes, usually it works just fine, that's why I ignore it at the first time.

But when I rule out everything else and try old school, publish the page to a localhost and open in a real Chrome, it worked!

I don't know where the real problem was or why the build-in browser is capable of rendering a massive amount of 3dtiles data but not a single string line, that leave to your esteemed Cesium developers to found out.

As for the file size, mine is very small so far, but I will keep a eye on it.