Ambient lightning for 3d tiles model

My 3d tiles model appears dark when not facing the lightning source, I disabled both the viewer.shadows and viewer.scene.globe.enableLighting but still no luck. The only way to make it appears lighter is by sliding the time slider so the model has lighting on it, I am wondering is there a way to get a ambient lighting( disregarding lightning source), for the 3d tile model.
Thanks

This may be related to https://github.com/AnalyticalGraphicsInc/cesium/issues/5787. The lighting is determined by a combination of the material and shaders inside the glTF model that is embedded in each tile. Feel free to send me a single tile and I might have some suggestions.

Thanks for sending me your tileset. Since the materials use KHR_materials_common the fix at https://github.com/AnalyticalGraphicsInc/cesium/issues/5787 will help provide some ambient light.

Forgot to mention, that fix should be in the 1.37 release on Friday.

在 2017年8月30日星期三 UTC+8上午10:27:44,Sean Lilley写道:

Forgot to mention, that fix should be in the 1.37 release on Friday.

Thanks for sending me your tileset. Since the materials use KHR_materials_common the fix at https://github.com/AnalyticalGraphicsInc/cesium/issues/5787 will help provide some ambient light.

This may be related to https://github.com/AnalyticalGraphicsInc/cesium/issues/5787. The lighting is determined by a combination of the material and shaders inside the glTF model that is embedded in each tile. Feel free to send me a single tile and I might have some suggestions.

On Monday, August 28, 2017 at 11:49:11 PM UTC-4, asu.x...@gmail.com wrote: My 3d tiles model appears dark when not facing the lightning source, I disabled both the viewer.shadows and viewer.scene.globe.enableLighting but still no luck. The only way to make it appears lighter is by sliding the time slider so the model has lighting on it, I am wondering is there a way to get a ambient lighting( disregarding lightning source), for the 3d tile model.
Thanks

Will test after the release. thanks for your help.

在 2017年8月30日星期三 UTC+8上午10:27:44,Sean Lilley写道:

Forgot to mention, that fix should be in the 1.37 release on Friday.

Thanks for sending me your tileset. Since the materials use KHR_materials_common the fix at https://github.com/AnalyticalGraphicsInc/cesium/issues/5787 will help provide some ambient light.

This may be related to https://github.com/AnalyticalGraphicsInc/cesium/issues/5787. The lighting is determined by a combination of the material and shaders inside the glTF model that is embedded in each tile. Feel free to send me a single tile and I might have some suggestions.

On Monday, August 28, 2017 at 11:49:11 PM UTC-4, asu.x...@gmail.com wrote: My 3d tiles model appears dark when not facing the lightning source, I disabled both the viewer.shadows and viewer.scene.globe.enableLighting but still no luck. The only way to make it appears lighter is by sliding the time slider so the model has lighting on it, I am wondering is there a way to get a ambient lighting( disregarding lightning source), for the 3d tile model.
Thanks

Just upgraded to 1.37, the back side is not completely dark and looks much better for now , so will Cesium team consider adding functionality to manually set the lighting for models, giving more customization to us developers.
Thanks

Traditionally we have let the glTF control all aspects of rendering itself, but I see your point. Once all models are glTF 2.0 and rendering with physically-based-materials there should be less problems overall. But there’s still a lot to do for making lighting in Cesium more configurable, hopefully something we will address soon enough.