Animated gltf not showing up

Hi folks

I have a gltf aircraft model that includes a simple animation (gear up/down).

It is displayed nicely in the following two online viewers:

However, I seems to cause troubles in and in my local cesium 1.41.

Do you have any ideas, why it fails in cesium’s viewer?

Attached you will find the gltf-file.

Any hint or tip is greatly appreciated, thank you! (4.31 MB)

Thanks for the bug report!

It looks like this model has the same animation bug that has affected a few other models in the past. I tested it with the branch and the animation worked correctly. That PR should get merged before the next release.

Sweet! Looking forward to 1.42 then :slight_smile:
Thank you!

Hey Sean

Can I please ask you a favor?

Could you also test the following model with your new code?

I now use a different exporter (3ds max to gltf), but still have no satisfying results:

  • the glb model is shown with animations, but it looks flipped (inside out), as though the normals are wrong

  • the gltf (with the bin) is not even shown in the virtualgis-viewer

Again, the other two viewers display the model including animations nicely without issues (and way shorter loading time).

I am just wondering, whether it is a viewer or model issue.

Hoping that your new code will fix this model as well!

Thx and cheers

Tim (2.93 MB)

I think the normals are correct but the winding order of the triangles is clockwise instead of counterclockwise, which means the front faces are being culled instead of the back faces. As a quick fix, edit the material in the gltf by setting doubleSided to true. It’s possible the other engines are doing this by default. Also, I tried both the .gltf and .glb in Cesium and they loaded fine, nearly instantaneous for me. I’m not sure what would cause the slowdown for you.

“materials”: [


“doubleSided”: true,

“pbrMetallicRoughness”: {

“baseColorFactor”: [






“metallicFactor”: 0.0,

“roughnessFactor”: 0.9


“emissiveFactor”: [





“name”: “Material #26




Sweet, thank you very much, Sean!
For the quick fix: Is there a way to change this property in a .glb? Or can this only be done in a .gltf?

For info, I reported this issue also on the 3ds max exporter.

It can only be done in the .gltf, but you should be able to convert it back to a .glb pretty easily (for example, here