Model not appearing, feel like its something with the dae/gltf?


I modeled out a simple arrowhead in maya and was trying to load the thing in. Given multiple approaches I seem to get no errors but can't see the model. Perhaps im missing something obvious?

Using Maya 2014, OpenCollada Exporter then a few different gltf converters. The drag and drop converter on the cesium website gives me a gltf that points directly to the texture. The github exporter generates glsl shaders for the same model, but when I load up both manually in the sandbox (just pasteing them into the sandcastle model example), I get zero js errors and no visible model. Strange.

Heres a pastebin of the gltf file, texture is just a 32x32 texture that is grey.

Of the things I have tried: forcing triangularization, using a colored texture over flat colored shader, different types of shaders, make sure normals are right, etc.

Really curious what im doing wrong.

Have you tried the bgltf option from the cesium website ? If it’s poiting to a texture file, then you’ve just told it to create the ‘older’ gltf file, the bgltf is the binary version, and it automatically includes the textures for you.

Ya, original version was just a lambert shader colored black without a texture. Tried to export that one from both the command line converter and the website converter in the binary and non binary formats with open collada maya plugin. For some reason both textured and untextured all the cesium javascript works, but no model is rendering. Strangest thing.

Hi Roger,

In our experience, issues like this are usually due to the COLLADA exporter. Have you seen the Troubleshooting section here:

After trying that, if you still have an issue, let us know if you can share the model.