Canceling GridImageryProvider from expanding?

Hi there,
I have a static grid on a map(for instance - about 2000 tiles).
I have managed to use GridImageryProvider to show the result that I want but the problem is that when I zoom in - it expands itself and suddenly there appear more tiles.

Is there any option to cancel it from expanding on a zoom?



This is how the GridImageryProvider is designed to work. I don’t know of a way to keep the tiles from popping in as you zoom,



If you want to grid the globe statically, I would suggest doing so with a collection of polylines