Cesium timeline localization problem

Hi guys, I’m currently using Cesium 1.41 inside my project with vue2 and I’m having trouble showing the correct localized time of the timeline widget.

**I’ve searched similar threads in this group on timeline localization and found the link **https://github.com/AnalyticalGraphicsInc/cesium/issues/5663.

I’ve tried the solution provided inside the link, but there’s a problem for the solution, the timeline always initially showed as UTC time, I had to drag the timeline slider to the leftmost

or rightmost and then drag back, and then the correctly localized time would appear. I also tried opening Chrome’s dev console(F12) and when I was resizing the console the timeline

also became the correct time display. Does it need some sort of refresh or does anyone have any idea on how to solve this problem? Thanks.


Were you ever able to resolve this? You might be able to trigger this “refresh” by forcing resize with this function: https://cesium.com/docs/cesiumjs-ref-doc/Viewer.html?classFilter=Viewer#forceResize