CesiumJS 1.50 search location rendering stopped

1. A concise explanation of the problem you’re experiencing.

I just download Version 1.50 and tested it on both Windows and Ubuntu system and both chrome and firefox. But the rendering has always stopped when i try to search a location.

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

An error occurred while rendering. Rendering has stopped.


RangeError: Invalid array length

RangeError: Invalid array length

at E (http://localhost:8080/Build/Cesium/Cesium.js:524:27635)

at S.createPotentiallyVisibleSet (http://localhost:8080/Build/Cesium/Cesium.js:524:30740)

at Ze (http://localhost:8080/Build/Cesium/Cesium.js:525:21759)

at Ye (http://localhost:8080/Build/Cesium/Cesium.js:525:19142)

at at (http://localhost:8080/Build/Cesium/Cesium.js:525:28346)

at st (http://localhost:8080/Build/Cesium/Cesium.js:525:28535)

at we.render (http://localhost:8080/Build/Cesium/Cesium.js:526:6664)

at A.render (http://localhost:8080/Build/Cesium/Cesium.js:532:16345)

at t (http://localhost:8080/Build/Cesium/Cesium.js:532:9795)

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

Just wanna search a location

4. The Cesium version you’re using, your operating system and browser.

Version 1.50

Chrome Version 69.0.3497.100 (Official Build) (64-bit)

Thanks for reporting this Shirui. I’m having trouble recreating this though. Does this only happen when you’re running locally, or can you recreate it in Sandcastle (https://cesiumjs.org/Cesium/Build/Apps/Sandcastle/) ?

What search string are you entering?

If it doesn’t happen in Sandcastle, can you try using the unminified version of Cesium and reporting the error there? I think the easiest way is to go to the hello world app (http://localhost:8080/Apps/HelloWorld.html) and change the code in HelloWorld.html from






Thanks a lot Omar.
I’m not able to reproduce this issue in sandcastle.

But I’ve tried your solution to use the unminified version of Cesium and the SEARCH function works now.

I’ve always used Version 1.42 and it has no problem regarding this. But since I updated to Version 1.50 and 1.49 (tried just now), this issue happens.

Hmm, this is quite peculiar. I wouldn’t have thought using the unminified version would fix it.

Does this happen with any search string you try? Are you typing these search strings in English or another language?

I think it is something to do with the cesium.js in build.

I tested different versions of Cesium and each version works in 'search function' until Version 1.49.

So I replaced the Ceisum.js file in Version 1.49/Version 1.50 with the one from Version 1.48 and the "search" function works.

BTW I always search in English such as Germany.

Ok, I was able to reproduce this now. I’ve isolated the cause but still not sure why it’s happening. More info here:


This is a pretty high priority, so hopefully we should see a fix pretty quick. Thanks again for bringing this up!

Looks like this has just been fixed with this PR (https://github.com/AnalyticalGraphicsInc/cesium/pull/7154) and should be included in the 1.51 release on November 1st. Thanks again for bringing this up!

Thanks for your info Omar! :slight_smile:
Glad that my report was usefull.