Earth is now black at all times in the editor

It displays fine at runtime and in a packaged exe but now the Cesium Earth is completely black at design time in the editor. All the objects I have added to the map are super over exposed and blinding until I zoom closer and then it adjusts but the Earth terrain stays solid black.

I have had this happen a couple of times now and when it happens I can’t get it working in the editor anymore. I am using the SunSky and have not changed anything and this seems to randomly start happening.

If I make a new map in this project and add the Cesium SunSky and the Cesium World Terrain the Cesium Earth is still black. It seems like the whole project is broken. I have tried switching to “Road Imagery” but that is black as well.

I wonder if anyone has seen this before as it makes it impossible to continue working on this project.

Thanks

Hi @format,

Sorry to hear you’re having trouble! I’ve noticed an issue before where SkyAtmosphere will cause the terrain to render black - SkyAtmosphere sometimes hides earth's surface · Issue #527 · CesiumGS/cesium-unreal · GitHub. Does this look like the same problem?

Try clicking on the CesiumSunSky actor, then the SkyAtmosphere component of Cesium SunSky. Set the Transmittance Minimum Angle from -90 to 90.

If that doesn’t help, would you be able to send me your project files so I can check it out? If you don’t want to post them here you can also send me a message.

-Alex

Thanks for the quick reply. It does look a bit like that but my issue could be slightly different. I tried setting th Transmittance Minimum Angle to 90 but that didn’t help.

Some more info based off reading that other thread that might help… I am not moving away from the longitude/latitude that I have set in the Georeference actor and the SunSky, it happens at my origin point. The other meshes I have added are super exposed, see the picture below.

Also, when I press play it looks great, its just like this in edit mode.

I just noticed this when I zoomed fully out as well, I have no land!

I can’t send over my project files I’m afraid as it is part of a larger project and is over 60GB. If you don’t have any more ideas based on this extra information I can maybe look at clearing it out so I can send it over. Oh I forgot to mention last time that I am on 4.26 if that makes a difference?

Thanks again for the help!

This is super odd… It looks like in editor Cesium World Terrain isn’t there at all. When CWT is hidden or not present in the level, the SunSky blueprint’s atmosphere will make it look like the images you posted above. But clearly it’s present in the level, since it works fine when you press play.

A few ideas:

  1. Is the tileset visible in the details panel?
    image
    It should have this eyeball icon next to it - if it’s hidden, the icon will be greyed out.
  2. Open the Output Log (Window>Developer Tools>Output Log). Are you getting any error messages?
  3. Are you doing anything at runtime to the tileset? Spawning it, modifying it, etc? If so, can you share your code or blueprints?
  4. Does this also happen if you create a brand new project?
  5. Are you adding Cesium World Terrain from the Cesium Quick Add panel, or adding the keys manually to new tilesets?

You mentioned it happened a couple of times and you can’t get it working in the editor anymore. If you were previously able to temporarily resolve the issue, what did you do to fix it? Can you think of anything that might have triggered it?

  1. Yeah the tileset is visible
  2. Not getting any error messages I can see
  3. No I am not doing anything to the tileset. I just have the ariel imagary and OSM buildings on and apart from that I am just placing my own meshes on the top
  4. It works fine in a new project
  5. I am adding the terrain from the quick add panel

To fix this issue last time I had to rollback to a previous backup. Then I worked on it for a few days and the same thing happened again. Unfortunately I can’t roll back to a backup anymore as I have made lots of changes to my code now.

I originally thought it might be to do with having to make my emissive materials super bright to actually show up on any map with the Cesium Earth and it was going crazy because of some auto exposure thing but I removed all of those meshes from the map and it is still super bright white on my meshes and black terrain. Plus as I said it still works fine in runtime which is strange.

I wonder if clearing out all Cesium references, removing the plugin and adding it all back in might help? I will see if I can give that a try.

Thanks again!

Edit - I just tried removing my Ion Access Token from my World Terrain and then putting it back. I then got “Received status code 401 for asset response”. Obviously I don’t get this when I do the same thing on a project without this issue, it just lists out the tiles it is loading like it should do. You are right that it seems the tiles aren’t getting loaded in the editor at design time for some reason.