ellipse appear gray when using Cesium.Color.WHITE

Is it because of lighting?


const ellipse = {
      semiMinorAxis : 10000.0,
      semiMajorAxis : 10000.0,
      material : Cesium.Color.WHITE,
      shadows: Cesium.ShadowMode.DISABLED,
      numberOfVerticalLines: 3,
      height: 10,
      outline: false
    const cartesian = Cesium.Cartesian3.fromDegrees(data.coordinates[0], data.coordinates[1])
    entity = new Cesium.Entity({
      position: cartesian,

macOS, Chrome (latest), Cesium ^1.32.1

mode = SCENE2D

Hi there,

Could you provide a more complete code example? Sandcastle actually makes it really easy to do this via the share tab at the top of the page, which will save and generate a link to a code snippet: http://cesiumjs.org/Cesium/Apps/Sandcastle/index.html?src=Hello%20World.html&label=Showcases

Thank you for your browser / OS information, but we’ll need slightly more context to determine the cause of this problem.


  • Rachel

I believe this is an open bug. https://github.com/AnalyticalGraphicsInc/cesium/issues/1825

In the meantime if you don’t include height it should work as expected.

Hm. It appears to be something else in my environment. I’ve disabled a lot of things (shadows and stuff) to optimize. I re-enable them until I find the culprit. Here it appears white as expected:


Maybe found my issue. See “contextOptions”. Only in SCENE2D. Not sure if expected or bug:


Thanks Jon. I think the stencil thing may be a happy accident, but I updated https://github.com/AnalyticalGraphicsInc/cesium/issues/1825 with a link to your gist and this thread.