Entities not showing

1. A concise explanation of the problem you're experiencing.

I try to reproduce the example from here :

I copy/pasted the exact same code, but cannot get it to work. While the example works fine in my browsers, I only get the globe to work properly, but no lines are displayed.

I then tried to modify the viewer parameters, which are working properly (terrain provider displays mountains, disabling widgets works as well).
I triggered a few breakpoints to make sure that viewer.entities.add() was actually adding data in the entities array, and I can confirm that the array has new objects after each add().
I also tried to change the line's width and color but to no end.
To keep it simple, I'll focus on a single polyline.
The polyline is not shown, the camera stays at default position, but the entities array has not object before the add(), and one object after.

2. A minimal code example. If you've found a bug, this helps us reproduce and repair it.

My page is structured like so:

<!DOCTYPE html>

        <link rel='stylesheet' href='./source/libraries/Cesium/1.45/Widgets/widgets.css'>


        <div id='cesiumContainer'></div>

        <script type='text/javascript' src='./source/libraries/Cesium/1.45/Cesium.js'></script>
        <script type='text/javascript' src='./source/view/3D.js'></script>


3D.js contains the following :

(function() {

  var viewer = new Cesium.Viewer('cesiumContainer');

  var redLine = viewer.entities.add({
    name : 'Red line on the surface',
    polyline : {
      positions : Cesium.Cartesian3.fromDegreesArray([-75, 35,
        -125, 35]),
      width : 5,
      material : Cesium.Color.RED



3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

I'm trying to display a polyline to represent a pedestrian pathway that needs to be in focus.

4. The Cesium version you're using, your operating system and browser.

Cesium 1.45, Mac OS 10.13.3, Safari 11.0.3, Chrome 66.0.3359.181, Firefox 60.0.1.

You’re code is correct and runs in Sandcastle. I’m guessing this is a problem with how you are importing script files. Do you have any errors in the console?