Google Photorealistic 3D Tiles, turn off collision?

Hello!

I am working on a project where I am integrating a archviz apartment into the Cesium Google 3D Tile set and have hidden the area where the apartment is located using the CartographicPolygon. But for some reason even when I haven set the google 3D tile set’s collision preset to NoCollision the player character still collide with the mesh when walking about in the apartment where I have my own collision on meshes.

I don’t need collision for any part of the Cesium model, is there no easy way to disable all collisions for the Google 3D Tile set?

I have added a Image showing the collision still represented in the Player collision view in the viewport even after turning off collision.

In advance, thanks for any help!

Hi @MetaMagnus, have you tried turning off “Create Physics Meshes” on the Cesium3DTileset?

2 Likes

Thanks for the tip Brian! :slight_smile:

Turned off “Create Physics Meshes”, but it unfortunately did not solve the issue.

But I figured it out, by going to custom on the collision preset and putting ignore on pawn solved it. Weird that the no collision filter did not work, but either way its solved.

1 Like