How to build the cesium(v1.49)

Some errors appear when I build the cesium(v1.49) following the instructions from here.

E:\yxf\yxf_code\cesium\cesium-1.49>npm install

npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5

npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js

npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

npm WARN deprecated nodemailer@2.7.2: All versions below 4.0.1 of Nodemailer are deprecated. See https://nodemailer.com/status/

npm WARN deprecated uws@9.14.0: stop using this version

npm WARN deprecated mailcomposer@4.0.1: This project is unmaintained

npm WARN deprecated socks@1.1.9: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0

npm WARN deprecated node-uuid@1.4.8: Use uuid module instead

npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

npm WARN notice [SECURITY] lodash has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=1.0.2 - Run npm i npm@latest -g to upgrade your npm version, and then npm audit to get more info.

npm WARN deprecated buildmail@4.0.1: This project is unmaintained

npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js

npm WARN deprecated socks@1.1.10: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0

npm WARN notice [SECURITY] timespan has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=timespan&version=2.3.0 - Run npm i npm@latest -g to upgrade your npm version, and then npm audit to get more info.

npm WARN notice [SECURITY] minimatch has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=0.2.14 - Run npm i npm@latest -g to upgrade your npm version, and then npm audit to get more info.

npm WARN notice [SECURITY] minimatch has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=2.0.10 - Run npm i npm@latest -g to upgrade your npm version, and then npm audit to get more info.

uws@9.14.0 install E:\yxf\yxf_code\cesium\cesium-1.49\node_modules\uws

node-gyp rebuild > build_log.txt 2>&1 || exit 0

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

Hi there,

Those instructions are for building from the Source. Are you using the downloaded zip? You should be able to just run npm install and node server.js as explained in the Quick Start Guide.

Thanks,

Gabby

Hi Gabby,

I want to build from the source.
I tried to build from the source on v1.47.
The same error came but with value 1.46, just one version before the current build version.
The above source I think is downloaded from github as the zip file.

Regards,
Tushar

I think you might just need to upgrade your Node/NPM versions. Try upgrading or just installing the latest version. And see if that fixes it.

I think you might just need to upgrade your Node/NPM versions. Try upgrading or just installing the latest version. And see if that fixes it.

> Hi there,

>

>

> Those instructions are for building from the Source. Are you using the downloaded zip? You should be able to just run npm install and node server.js as explained in the Quick Start Guide.

>

>

> Thanks,

> Gabby

>

>

>

>

> Some errors appear when I build the cesium(v1.49) following the instructions from here.

>

>

>

>

>

>

> E:\yxf\yxf_code\cesium\cesium-1.49>npm install

> npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5

> npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js

> npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

> npm WARN deprecated nodemailer@2.7.2: All versions below 4.0.1 of Nodemailer are deprecated. See https://nodemailer.com/status/

> npm WARN deprecated uws@9.14.0: stop using this version

> npm WARN deprecated mailcomposer@4.0.1: This project is unmaintained

> npm WARN deprecated socks@1.1.9: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0

> npm WARN deprecated node-uuid@1.4.8: Use uuid module instead

> npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

> npm WARN notice [SECURITY] lodash has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=1.0.2 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info.

> npm WARN deprecated buildmail@4.0.1: This project is unmaintained

> npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js

> npm WARN deprecated socks@1.1.10: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0

> npm WARN notice [SECURITY] timespan has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=timespan&version=2.3.0 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info.

> npm WARN notice [SECURITY] minimatch has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=0.2.14 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info.

> npm WARN notice [SECURITY] minimatch has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=2.0.10 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info.

>

>

> > uws@9.14.0 install E:\yxf\yxf_code\cesium\cesium-1.49\node_modules\uws

> > node-gyp rebuild > build_log.txt 2>&1 || exit 0

>

>

> npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):

> npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

>

> The build process cannot passed:

>

>

>

> E:\yxf\yxf_code\cesium\cesium-1.49>npm run build

>

>

> > cesium@1.49.0 build E:\yxf\yxf_code\cesium\cesium-1.49

> > gulp build

>

>

> [18:46:10] Using gulpfile E:\yxf\yxf_code\cesium\cesium-1.49\gulpfile.js

> [18:46:10] Starting 'build'...

> error: Could not access '1.48'

> Failed to retrieve list of new Sandcastle demos from Git.

> [18:46:13] Finished 'build' after 2.73 s

>

>

>

>

>

>

>

> --

>

> You received this message because you are subscribed to the Google Groups "cesium-dev" group.

>

> To unsubscribe from this group and stop receiving emails from it, send an email to cesium-dev+...@googlegroups.com.

>

> For more options, visit https://groups.google.com/d/optout.

Hi Gabby,

I want to build from the source.

I tried to build from the source on v1.47.

The same error came but with value 1.46, just one version before the current build version.

The above source I think is downloaded from github as the zip file.

Regards,

Tushar

No change Omar

D:\cesium-master>npm run build

cesium@1.49.0 build D:\cesium-master
gulp build

[23:10:30] Using gulpfile D:\cesium-master\gulpfile.js
[23:10:30] Starting 'build'...
error: Could not access '1.48'
Failed to retrieve list of new Sandcastle demos from Git.
[23:10:33] Finished 'build' after 2.4 s

Part of the build process interacts with the Git repository for Cesium, which requires a git clone. However, the dependency is optional, so this message does not indicate a real error and can be ignored. The build is completing successfully.

Hi Scott,

Yes but it shed only minifyShaders.state and rest got ignored.
Though I am probing gulpfile.js along with package.json to check about the calls and dependencies.

Instead of importing in SVN I downloaded the zip, as SVN was not importing and some communique errors dislodging the import process.

Do I have to however compel importing, to perfectly align the dependencies?

Regards,
Tushar

Check the Contributor’s Guide for information on the different build targets and what they do:

https://github.com/AnalyticalGraphicsInc/cesium/tree/master/Documentation/Contributors/BuildGuide

Thanks Scott, I will surely go through the implications of this build process from the provided link.

For the time being, I used "npm run release" or "npm run minifyRelease" and it made the build though did not prepared the sandcastle examples, but its ok my need of the situation was the build.

I did not needed the minified version of JS so went on to run "npm run release".

Thanks once again for leading me to the solution.