Issues using ellipse outline without computeEllipseBoundary


I recently upgraded to version b30 and had to move to using EllipseOutlineGeometry
(instead of computeEllipseBoundary).

When I was using computeEllipseBoundary to create an ellipse it was easy to:
1) change the location of the ellipse (by setting the positions array)
2) change line width
3) save all the ellipses in a simple collection

With EllipseOutlineGeometry:
1) how do I change ellipse position?
2) how do I change the line width? (in chrome scene.maximumAliasedLineWidth = 1)
3) Is there a simpler way then saving my ellipse in a primitiveCollection as a Geometry Instance?

Thank you,

I’m also missing the compute boundary functions of Ellipse and Circle. You can either copy paste the code to generate the positions OR you can actually retrieve these positions, ie the same array of positions than computeEllipseBoundary used to return, by creating the ellipse geometry outline and accessing the geometry position array using geometry.attributes.position.values, you’ll have to transfer it to a Cartesian3 array to get the same result.

I also have issues with scene.maximumAliasedLineWidth which is always 1, any idea why? I used to be able to draw thicker lines than that.

Deleted my suggestion... I tried it and it didn't work. I'm going to copy the old computeEllipseBoundary code and make it part of my project.

I’m also having the same problem, any way of getting the code back to the next release ?


this is true! I am also facing the same issue with scene.maximumAliasedLineWidth, which is always 1. I am trying to increase the width/thickness of line, but am not able to do so.

Could you please suggest any other way to increase the width of a line?

Thanks & Regards,


I recently answered this question on Stack Overflow, here’s the link: