Issues with sequencer

Hi all,
I am using unreal 5.3 with bing maps/world terrain and have had this issue for a while-it seems others have also had it. I’ve tried some of the solutions, but still having problems sadly.

When I export a movie from Sequencer the first few frames do not load tiles before rendering.

This seems to be the case even if I add a level to the samples project (I have added a sublevel to the sublevel in the samples project and have the same problems). I also have other artefacts whilst rendering, am assuming its related/the same thing.
At the moment I am stuck to just screen recording the viewport but as you can imagine this isnt ideal.

Any idea what could be causing it?
If its useful to know I didnt make the cinecameras within sequencer, but dragged them in from the outliner. The sequence itself is part of the level though.

Hi @H_S,

Can you provide us with more details so we can troubleshoot?

  • What version of Cesium for Unreal are you using?
  • Were you able to use Sequencer successfully on previous versions?
    • If so, which ones?
  • Can you use Sequencer on Cesium for Unreal Samples successfully (without any modifications)?
    • If so, walkthrough step-by-step how you set up the level that won’t work with Sequencer.


I’m not sure how to check which version of cesium.

I installed it from the marketplace and havent been asked to update so am assuming it’s the latest version available on the epic games marketplace.

I have never been able to use sequencer without tile rendering issues.

Have now setup a basic camera animation with the samples project (04, sublevels)
It now says the sub levels are set to blueprint streaming and will not be visible during a render Now i am just getting black frames.

Setup: opened 04 maps, main, selected boston sub level.
Created a camera and dragged it into the sub level.
Created a sequence within the level using the button next to selection mode. The sequence is part of the sub level.
Saved the level sequence in the same folder as the sub levels.
Dragged the camera into the sequence. Made keyframes.
Used the movie renderer queue, jpg sequence.

Thanks for your reply, hoping I have missed an obvious setting somewhere!

Hi @H_S,

Are you using “warm up” frames at all? 3D Tiles require several frames to actually load in, so you’ll want to set the “Render Warm Up Count” or “Engine Warm Up Count” to around 30-60 frames before rendering. Here’s a tutorial that goes in-depth about those settings.

Please check the plugin version by going to Edit->Plugins->Geospatial. The Unreal Engine Marketplace doesn’t automatically update plugins (though it does make it easy).

I’m not sure we’ve tried putting a sequence in a sub-level before, so that could be the problem. In particular, the automatic “wait for tiles to load before snapping” functionality requires that all the Cesium3DTilesets be able to find the Level Sequence. They probably won’t be able to do that if they’re in different levels, i.e., the Level Sequence is in a sub-level and the Cesium3DTileset is in the persistent level.

Sorry for taking a while to get back to you all on this.
I’m on version 2.0.0 of cesium now.

I have made a different animation using the samples project and it renders ok. This is a normal level and not a sub level so I am assuming youre right that this wont work with sublevels…which is a bit sad :frowning:

I have tried warm up frames in the past and had issues with camera moves that rotated to reveal environments, since we weren’t already looking in that direction there was nothing being loaded in.

Sorry I know it suddenly working isn’t much help for troubleshooting.