Sublevels not loading while rendering from sequencer

I have sublevels being managed by a CesiumGeoreference (as described in the Building Global Scenes with Georeferenced Sublevels cesium learn article). While the visibility toggling appears to work fine in the editor and at runtime, when rendering from sequencer, it looks like the sublevels are not streaming in.

Although the streaming should be managed by the georef, I’ve also tried adding a sublevel visibility track in sequencer - also has no effect.

Tried in release 1.27 and 1.28, UE 5.1

The sub-level switching is controlled by the location of the “Sub Level Camera” property on the CesiumGeoreference. If one isn’t specified, it users the first player controller’s “Player Camera Manager”. So my guess is that your video is being rendered from the perspective of some other camera, so the sub-levels aren’t switching when expected.

Another possibility is that the tilesets are just taking too long to stream in. Cesium for Unreal will automatically wait for all tiles to be loaded before snapping each frame, but only if your level sequence is inside your level. If it only exists as an asset in the content browser, the automatic waiting won’t work.

Thanks for the response @Kevin_Ring -

  1. What type is the “Sub Level Camera” ? It seems that both CameraActor and CineCameraActor types in my level are not compatible with this property, what should be set here? In the BeginPlay event of my persistent level, I am setting the view target of PlayerController[0] to the CineCamera that I am using in sequencer.

  2. My sequence is in fact part of my Actor hierarchy within the persistent level (it’s visible in the outliner). The tiles look fully detailed and fine, my issue is just with sublevel visibility.

What type is the “Sub Level Camera” ?

It’s an APlayerCameraManager. I realize this isn’t ideal and we have some improvements planned.

If you can, it might be helpful to try stepping through this code in the debugger and see if it’s finding the camera manager successfully and whether its position corresponds to your CineCamera:

The tiles look fully detailed and fine, my issue is just with sublevel visibility.

Can you share a sample project with us to help reproduce this problem, then? Ideally starting with Level 4 of the Cesium for Unreal Samples project.

@Kevin_Ring apologies for my confusion here - I had another sublevel with a very large radius that was taking over as the current sublevel, and seems to be preventing the loading of the sublevel I was expecting to see. Is this mutually exclusive sublevel behavior expected?

Yes, only one sub-level can be shown at a time. This is because an active sub-level changes the Unreal coordinate system to be centered at the sub-level’s location. It’s not possible for the Unreal coordinate system to be in two places at once.