KML file markers not displaying properly

I’m trying to display a KML file that consists only of markers. It has no height information at all, field isn’t populated. How can I display it so that the markers show without being overwritten by terrain (I’m guessing that’s the problem).

    viewer.dataSources.add(Cesium.KmlDataSource.load('$(KML_FILE)', {
        canvas: viewer.canvas,
        clampToGround: true

Because I’ve had problems with clamp to ground with my data points I’ve written code to use sampleTerrain to compute heights. But I’m having trouble doing this for a KML file. If I look at the entities in the debugger the positions are 5/6 digits x/y/z values. How can I loop through a KML file and get the lat/long values for each point?

var promise = viewer.dataSources.add(Cesium.KmlDataSource.load('$(KML_FILE)', {
        canvas: viewer.canvas,
    promise.then(function(dataSource) {
        var cart = new Cesium.Cartographic();
        var entities = dataSource.entities.values;

        for (var i = 0; i < entities.length; i++) {
            var entity = entities[i];
            pos = Cesium.Cartographic.fromDegrees(????,????, 1000, cart);

What replaces the ???

Have you taken a look at the disable depth test option? See Cesium Sandcastle and select “Disable the depth test when clamped to ground” option from the dropdown.

You can similarly disable depth test for your KML entities as well.

The depth test disable doesn’t seem to affect anything. It’s mentioned the in he documentarian for Billboard but not KmlDataSource. Does KmlDataSource support it?