Lighting of models in 2D map view

1. A concise explanation of the problem you’re experiencing.

I have entities with a 3D model displayed on the map in the 2D view. As I pan around, the models get darker and darker the closer they get to the edge of the viewing area, until they are black. I assume this is because the light is directed at the center of the viewing area. In the 3D view, this is never an issue because I’m not looking at the ‘dark side’ of the map until I spin the globe, which changes where the light shines.

Is there a way to completely disable this so that the entire area is ‘lit up’? I tried setting all shadow settings I could find to disabled. Is there more I need to do?

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

I will have to setup a minimal code example. I can come back and do that if the answer isn’t simple.

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

My use case only requires the 2D view. I would like the entire area to appear uniform.

4. The Cesium version you’re using, your operating system and browser.

Cesium 1.56, latest Firefox and Chrome.

I tried using one of the models in the Cesium Sandcastle and it seems that the issue is my 3D model. The Cesium model doesn’t have the same problem. That being said, if there is a Cesium setting that might help me (as opposed to having to edit my model), I would greatly appreciate your advice. Thanks.

There are a couple of things you could do, like the settings described in this forum thread, if you haven’t already tried them:

Let me know if any of those help. If you’re able to share this sample model and a Sandcastle example, I’d also be happy to take a look.

What kind of project are you working on?