limitations in dae?

Hello, I rework some downloaded models in collada with blender and some can't be converted to gltf.
Are there some limitations in the converter?

Some files which don't work with the converter in attachment (1.26 MB) (3.36 MB)


Have you tried the tips here:

Let us know if you are still having issues, and we’ll have a closer look.


Thanks, I’ve confirmed that these fail with the current converter, I wrote up an issue for us to look into it.

I just updated the server with a new version of the converter. Both of your models now convert without any issues. That being said, the YF40 model will still fail because it takes too long on the server (we don’t allow conversions to run for more than a few minutes in order to prevent runaway processes or from someone DOSing the server.). That being said, I’ve attached the converter YF40 model for you, which I ran locally.

Thanks again for the bug report and let us know if you have any more problems.

Let us know if you have any other problems and thanks for the bug report. (3.41 MB)

thanks for the conversion. For my part, I cloned the github repository of glTF ( and I could generate the gltf without the webService that you provide.