Loading local vtk generated glTF files


I am working with Cesium to visualize some georeferenced ParaView results.
VTK has a native glTF exporter.

I’ve exported a simple Cube from ParaView and was able to show it in Cesium just fine with this piece of code.

    var cube = viewer.entities.add({
      name: "Cube",
      position: position,
      model: {
        uri: './Source/Assets/Images/Models/cube.glTF',
        scale: 100,
        minimumPixelSize: 128,
        maximumScale: 10000,

Then, exported this follow scene with same parameters: glyphs.gltf (1.3 MB)
Checked to see if it’s a valid glTF in https://gltf-viewer.donmccurdy.com/, and it’s fine.

Try to load it in Cesium, but to no success.
Changing 3D object’s scale in ParaView or in Cesium didn’t help

Does someone have a light to shine in this matter?

thanks in advance, and good holidays =)


Although the model loads in other viewers, it looks like the glTF might be invalid by the strict definition of the spec. I tried running it through the glTF validator here and it failed: glTF Validator
This is likely why it is not showing up in Cesium. Sorry I don’t have other suggestions for fixing this.

Best regards,


Thank you for the suggestion, Hannah!

The geometry was not centered around the origin. That’s why it was ‘not showing up’ in Cesium.
(it was showing but in a random place)

After all, the glTF files generated through the VTK exporter are valid =)

While researching for a web mapper, I saw that Cesium accepts the following:

I have tried to load .dae and .fbx files the same way as the glTF but to no success.

Is there a difference in the process for other extensions?

Thanks in advance!

The process should be the same for fbx and dae file. Do you mind sharing here or in support@cesium.com the asset ids of the models that you failed to upload?

Hi, Dzung!

They are local files, only through ‘Cesium Ion’ models have an asset id, right?