LogCesium Error 403

I put the Map Tile API that I fetched from the google maps platform account, next to the link ‘https://tile.googleapis.com/v1/3dtiles/root.json?key=’.
inside Cesium3dTileset0 in URL with the Source "from URL
and it ends up returning this log.

OutputLog "LogWindows: LaunchURL https://community.cesium.com/
LogCesium: Warning: “Enable World Bounds Checks” in the world settings is currently enabled. Please consider disabling it to avoid potential issues.
LogCesium: Loading tileset from URL https://tile.googleapis.com/v1/3dtiles/root.json?key=AIzaSyCAmAe-rSUfku5FOYdUF1SxKLSaTSE36GQ
LogCesium: Loading tileset from URL https://tile.googleapis.com/v1/3dtiles/root.json?key=AIzaSyCAmAe-rSUfku5FOYdUF1SxKLSaTSE36GQ done
LogCesium: Error: [2023-06-09 20:41:14.160] [error] [ErrorList.h:72] Errors when loading tileset:

It takes a little while for Google API keys to become active. Are you still having trouble? If so, double-check that you’ve copied the API key correctly, with no extra spaces or anything like that.

@Kevin_Ring I am getting same error. I restricted my API key by IP address could this be the issue?

I’m not sure. I suggest trying without it, or asking Google. There’s nothing on the Cesium end that would care whether the API key is restricted by IP address, as far as I know.

Hey Kevin, I experience the same issue as Chrishunk also

LogCesium: Error: [2023-06-21 16:09:41.846] [error] [ErrorList.h:72] Errors when loading tileset: - Received status code 403 for tileset [https://tile.googleapis.com/v1/3dtiles/root.json?key=](https://tile.googleapis.com/v1/3dtiles/root.json?key= MapsAPIKey

I have followed cesium and Google Maps Platform guides to the best of my knowledge and don’t know what I am doing wrong along the process. I have been trying this over a few days now and at the most on the Google Maps Platform it says it takes up to 5 minutes for the key to validate.

1 Like

If you’ve already double-checked that the key is enabled for the correct services and that is has been provided to Cesium correctly, then I think all you can do is reach out to Google and ask them what’s wrong.

Ok, will do thanks Kevin

One other thing I just thought of: it may be useful to copy the URL you’re providing to Cesium into a web browser, and see what you get when you try to load it. It might provide some useful diagnostic information.

Hello, I had a similar error and I solved it by activating the google cloud API of “Map Tiles API”


Thanks @Pena_Daniel. That’s definitely a necessary step. Is it not covered by the tutorial?

For the record, this is indicated as necessary under the Prerequisites section of the tutorial :slight_smile:

1 Like

Thanks man!!

Thanks that was it!

Thanks Daniel!!

Thanks Janine