Google Maps API returning 404 error in Cesium Unreal plugin

I am trying to use the Cesium plugin for Unreal Engine to display Google Maps, but am running into a 404 error when loading map tiles.

I have followed all the instructions in the Youtube tutorials exactly. I have also tried generating multiple new API keys on Google Cloud Platform, with the Maps JavaScript API enabled. However, every time I enter the tileset URL into Cesium, I get this 404 error:

"LogCesium: Error: [2023-07-20 23:08:40.601] [error] [ErrorList.h:72] Errors when loading tileset:

I have rebooted both my computer and Unreal Engine multiple times, but the issue persists.

Things I have tried:

  • Triple checked the API key is valid on Google Cloud Platform
  • Generated new API keys and verified Maps JS API is enabled
  • Copied the tileset URL format exactly as shown in docs
  • Tested accessing the tileset URL directly in browser

At this point, I’m wondering if it could be an issue on Google’s end causing the 404 when accessing the tileset. Or maybe there is something incorrect in my Cesium setup.

If anyone has experienced a similar issue getting Cesium working with Google Maps, I’d appreciate any pointers on where I should look to resolve the 404 error. Let me know if any other details would help troubleshoot this. Thanks!

I think you need the “Map Tiles API”, not the “Maps JS API”.

You can also try visiting the URL you’re giving to Cesium in a normal web browser, and see what the Google API returns. There may be a hint in there.

Hey thanks I was able to fix it. It was a problem on Googles end. Luckily I have another Google account and I decided to try using that one and it happened to work.

Can you tell me did you purchase the maps api

i dont know this subject is still active but i tried many things but i still recieve a 404 i dont know whats causing it i have the map tiles API on

This issue has been covered many times in this forum, and usually it starts working for folks eventually. Some things that have worked:

  1. Wait an hour. Sometimes it takes that long for a key to become active.
  2. Double-check that you’re using the right key, and that they key has the Map Tiles API enabled.
  3. Make sure you’ve haven’t put any other restrictions on the key. Cesium for Unreal won’t set the Referer header the way a browser does (because there’s is no referring page in Cesium for Unreal), so restrictions based on that will not work.
  4. Check the Output Log for any messges that might provide a clue as to the cause of the failure.
  5. Visit the URL you’re poviding to Cesium for Unreal in a normal web browser, and see what response you get. The response text may offer a hint about what’s wrong.
  6. Create a brand new key and see if that works any better. Don’t forget to wait an hour for it to become active.

If none of that works, you’ll almost certainly need to take the issue up with Google.