Materials of Tileset are pink

Hi, recently Cesium tilesets have started showing that pink material, typical on Unity when there is an error. I tried “Convert material to URP” but this didn’t work, so I removed the Cesium package from the project and imported the most recent one, the problem was solved. Today, however, the problem is back and even re-importing the package does not solve the problem. Help me please.

My Unity Version: 2022.3.4f1
Cesium package: Old) 1.10.1; New) 1.11.0

Hi @Mattia_Politi, welcome to the community!

Thanks for including the details about your plugin version and what you’ve tried. Sometimes the materials won’t compile until you refresh the shader graph asset that is attached to them. Could you open the shader graphs (CesiumDefaultTilesetShader and CesiumUnlitTilesetShader), and click Save Asset in their editors? That will force them to recompile and transmit their changes to the materials.

If that doesn’t work, could you let us know if you see the same problem in a new, empty project? The ability to consistently reproduce this error will help us more reliably debug it. Thank you!

Hi Janine,
thanks for the answer.

I don’t know why, but the day after this post I opened the project and the problem was solved.