MultiPolygon from GeoJson not rendering correctly

1. A concise explanation of the problem you’re experiencing.

I am rendering a large Multipolygon from a GeoJson. The polygons render, but there are artifacts present. Sometime, the polygons overlap and extend out (see attached pictures).

I copied the same GeoJson in and it looks fine. I also tried rendering them as individual polygons in cesium and they looked correct. So I don’t think the GeoJson has invalid points.

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

Sandcastle example

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

I just need to be able to shade the inside of a multiPolygon that I get from a server. I tried rendering them as individual polygons but that had other issues.

4. The Cesium version you’re using, your operating system and browser.

Cesium 1.50.0, Windows 10, Chrome

Thanks for the help

Thanks for reporting this. I think it’s the same issue as:

It seems to work if you change the arc type, like in this example.

Thanks Omar! That fixed the problem.