My Entity height data is sea-level, but Cesium thinks in height above ellipsoid.


I've noticed a disagreement between my height data in my CZML (sea level values) and the calculated (interpolated) height reported at runtime ( I see the runtime values by attaching a listener and watching the Entity position change as the Entity travels).

So, we know that height is taken as height above ellipsoid ( see ), and that the ellipoid does not necessarily follow sea level.

Question: Do I need to attach a terrain provider to correct this problem?

Thanks !

I posted a similar question a while back. This may help

I found that discussion, which is very good. Thanks. The title is "CesiumTerrainProvider V VRTheWorldTerrainProvider Heights"

Thanks Aaron!

Links to posts don’t work if you use the domain, though I see that tho managed to find it anyways. That’s why instead of going to I goto!forum/cesium-dev instead as making links from there actually work.

This just leads to main forum page

This is what google groups gives as a link

Then it changes to this form once entered!msg/cesium-dev/Xz6_FnCuGNA/g

I tried removing the last character on the link but it wouldn’t work anymore.

I tried changing all the %2F to forward slashes

But it still didn’t work.