Point cloud data loading error

In the Unreal Engine, every piece of data looks vertical

and it seems normal in the web of cesium

i don’t know what’s wrong with my unreal engine,the vesion of unreal engine is 5.1.1 and the version of cesium for unreal is lastest

Are you able to share your dataset? I don’t know off the top of my head why the transforms are different, so we’d need to look at the data ourselves to figure out what’s wrong.

Can you send me an email address?

My email is janine@cesium.com.

It has been sent to your email

Hello, Have you solved this Problem? I also encountered this problem.


@XmissRP I am still looking into what’s causing the rotation issue. How are you viewing your dataset in the web? I tried to load your dataset into CesiumJS for debugging, but it doesn’t load because of a “too many shader attributes” error.

The original data is a file in las format. I previously imported it into cesium for slicing, and then the website can automatically load the data. I can send you the las source file.

I looked at your tiled data and it says it was tiled by cesiumlab. We are actually not affiliated with cesiumlab, so if you are tiling and viewing your data through them, I can’t guarantee that it will show up consistently with Cesium’s official runtime engines.

In fact, I tiled your point cloud via Cesium ion and it renders as expected in Cesium for Unreal…

… as well as Cesium for Unity:

So the original data must have been tiled with an incorrect orientation.

Ok, I understand why. Thank you for your help