Preserving speed on dynamic pawn?

So how does one achieve that? Dynamic pawn has desirable navigation, but when i adjust speed on it with the mouse wheel, speed is reset back to default if you stop and then start moving again. Couldn’t find any settings relevant to this.

Anyone has an idea where to adjust this behaviour in plugin sources? Or maybe i missed some setting?

Hi @Alexander_Drozdoff,

I hadn’t noticed this behavior before. In the Dynamic Pawn’s details panel, there should be a setting about dynamic speed. Does turning this setting off help?


That disables the dynamic speed altogether. I just want to preserve users’ adjustments to dynamic speed.

Hi @Alexander_Drozdoff,

Thanks for clarifying! I see what you mean now.
It looks like the Dynamic Pawn’s dynamic speed setting will reset the speed multiplier when the pawn is not moving. This functionality is located in the “Update Pawn Speed” function of the DynamicPawn blueprint.

Disconnecting that node should do what you need. However, I don’t recommend modifying the DynamicPawn directly - changes to plugin blueprints tend to cause problems on updates. I recommend duplicating the DynamicPawn blueprint and putting the duplicate in your project’s content folder. Then, disconnect or delete that node on your new duplicate blueprint, and use that pawn in all your levels.