Quality is really awful

Hi Everybody,
Does anyone know why I can’t see all the 3Dtiles in my VR headset? I am using Xr interaction toolkit 2.4.0. The quality is really awful…

What are the settings on your Cesium 3D Tileset? Typically, reducing the “Maximum Screen Space Error” is what we recommend to get higher levels of detail.

I left it at 16…

Some 3dtiles are not showing… I haven’t really touched the basic settings.

Thx Greg, but I still have the same problems but thanks anyway. :smiley:

Go to your XR origin and find your Main Camera. In the inspector set camera to Near 0.3 and Far to 1000000.

That’s what I did.
I will start from the beginning.

Make sure you don’t have any other cameras in the hierarchy. Remove main camera from the default screen setup. Otherwise Unity will render first camera that it finds. You only have to have one camera under XR Origin.

Try setting the Maximum Screen Space Error lower. Maybe you need it as low as 2-4 for your purposes.

Allways the same problem…
I wonder if the problem wouldn’t come from XR interaction toolkit 2.4.0…

Can you give a screenshot of your Unity project? Include the hierarchy, and make sure to select camera under the XR Origin, so I can see the settings. Are you sure you don’t have any other cameras in the scene, cause it happened to me as well.


So, another thing is that you might be looking at your scene in the Scene view, which will show you terrain like this, it will be clipped. But when you test it in the headset, it will work fine. You can also test it by dropping “XR Device Simulator” in the hierarchy and test it in the play mode. It will work fine.

I’m using version 2021.3.28 with a Pico 4.

Try refreshing “place origin here” of Cesium tileset. And also maybe add one more 0 to the Far clipping plane, since you are placing your XR origin so high up.

No it doesn’t work. I changed the start coordinates but strangely the start remains at the previous place.

There are some missing planes in the Scene view, but in the main camera preview everything looks fine to me.


Yes for me too…
I changed the XR interaction tool kit version, changed the pico version,
I started from the beginning… I even tried on a Quest 2, still the same problem.
I don’t understand ,However everything was working for a while…

Where can I download an older version of Cesium?

Thank you Evgeniya for taking the time to help me.