VR Problem with missing tiles

Hi, playing around with Cesium for Unreal - whoa, it’s really cool. What a pity that we have to use those lousy “bing” satellite images. :slight_smile:

However, my main problem is that, when using “Play in VR”, a lot of the tiles are not rendered, mostly the ones at the bottom. They do appear if I actively look down, but will disappear again as soon as I look up. I’m attachin a screenshot that shows what the problem looks like.
It seems like “something” regards these tiles to be "out of visibility and skips them from rendering.

Problem occurs with both cesium from the marketplace, and also a “fresh” one directly from the build server.

Any hints?

Hi @hwacookie,

Your guess is probably correct. For some reason, Cesium for Unreal thinks your camera’s view is different than it actually is. One possible cause is if you have multiple cameras in your scene and Cesium is choosing the wrong one. If you’re up for it, do a debug build of Cesium for Unreal and set a breakpoint in ACesium3DTileset::GetCamera. Take a look at how Cesium is obtaining your camera and see if it seems correct for your setup.

Kevin

1 Like

Ah, I just figured out how to fix this, so just in case anybody else stumbles over this: For VR, one must disable “Enable Frustum culling” in the “Tile culling” section of the CesiumWorldTerrain. Unfortunaly, this seems to cause a performance hit, too. But it’s better than a hollow landscape.